View unanswered posts | View active topics It is currently Fri Apr 18, 2014 10:53 am



Reply to topic  [ 4 posts ] 
 Rendering Issue (Stops) 
Author Message
Site Admin

Joined: Tue Aug 06, 2002 7:01 am
Posts: 24
Location: Thunder Bay, ON, CA
Post Rendering Issue (Stops)
In my new game, I have a tiled map for my game and I have layed out the map, but it stops rendering the map at a certain point. I have put a screenshot up of the problem here:

Screenshot

I don't know why it just stops rendering there, and there is no error output in my debug file.

Secondly, my program crashes/closes by itself if I hold one of the keys down for a certain amount of time [img]images/smiles/icon_confused.gif[/img] . Any ideas?

Help? [img]images/smiles/icon_sad.gif[/img]

Thanks in advance.
-Terry [img]images/smiles/icon_smile.gif[/img]

[ July 30, 2003: Message edited by: Hackin' ]</p>


Wed Jul 30, 2003 1:27 pm
Profile WWW

Joined: Sat Apr 21, 2001 7:01 am
Posts: 53
Location: Lexington, MA, USA
Post Rendering Issue (Stops)
This is just a guess, but maybe you're accidentally offsetting the drawing to the left by a certain amount. Try adding 200 pixels or so to the x-coordinate and see if you get a big black space on the left. If you do, then for some reason you're just not drawing enough tiles. If you don't get a black space, then for some reason you began your drawing too far to the left.


Wed Jul 30, 2003 3:01 pm
Profile ICQ
Site Admin

Joined: Tue Aug 06, 2002 7:01 am
Posts: 24
Location: Thunder Bay, ON, CA
Post Rendering Issue (Stops)
Thanks, Ben. I had a second look at my array data and I realized I had the MapHeight and MapWidth coords switdhed around in my tile rednering method [img]images/smiles/icon_biggrin.gif[/img] . Thanks for the help.

-Terry [img]images/smiles/icon_smile.gif[/img]


Thu Jul 31, 2003 2:35 am
Profile WWW

Joined: Tue Sep 12, 2000 7:01 am
Posts: 11
Location: England
Post Rendering Issue (Stops)
I assume your map is scrolling with the car as you press the arrow keys ... are you sure that the game isn't scrolling past the bounds of your tile array? That is, trying to render junk data? That could be the cause of the black tiles (no tile is rendered as the data is no good (out of bounds of your array) and the buffer is cleared to black each frame), and would be a sure fire way to cause the app to crash if you carried on scrolling. I have had similar problems to this before, and after a little debug I found out that the camera co-ordinates I was converting to an index into the tile data array were too high (scrolled too far) and resulted in a bad index and hence crashes, bad rendering etc.

[ July 30, 2003: Message edited by: Ben ]</p>


Thu Jul 31, 2003 6:50 am
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware.